WordPress Türkçe 4.2.4 yayınlandı !

WordPress Türkçe 4.2.4 yayınlandı

WordPress Türkçe 4.2.4 yayınlandı. Hemen güncelleyin !

WordPress, geçtiğimiz haftalarda 4.2.2 sürümünde kritik güvenlik açıkları olduğu için 4.2.3 sürümünü yayınlamıştı. 4.2.2 sürümümündeki açıktan olsa gerek geçtiğimiz hafta 62 adet wordpress kurduğum site RedHat tarafından hacklenmişti. WordPress Türkiye ‘den gelen açıklamaya göre 4.2.3 sürümünde de üç adet çapraz-site betik açığı bulunuyor. Ayrıca güncelleme 4 adet sorunu ortadan kaldırıyor. Güvenlik açılarından ve hatalardan dolayı Wordpress Türkçe 4.2.4 sürümünü yayınladı.  Wordpress ‘in Türkçe 4.2.4 ile gelen değişiklikleri buradan inceleyebilirsiniz. Genel olarak WordPress ‘i otomatik güncellemeye almanızı öneririm. Bazen güncellemeleri fark edene kadar hackerlar bu açıkları tespit edin sitenizi hackleyebiliyor. WordPress ‘teki bu kritik açıklara wordpress ‘in güvenlik eklentileri çok büyük etken oynamıyor. WordPress güvenliği için almanız gereken önemli tedbirlerden bazıları.

  1. WordPress sürümünüzü daima güncel tutunBunun için yapmanız gereken tek şey config.php dosyanızın içine define( 'WP_AUTO_UPDATE_CORE', true ); kodunu kopyalamanız yeterli. Böylece WordPress yeni sürüm yayınlandığında siteniz otomatik güncellenecek.
  2. Otomatik Yedekeleme Alın.WordPress ‘in en popüler eklentilerinden seçerek belirlediğiniz tarihlerde sitenizin yedeğini almanızı öneririm. Dosya olarak en az iki yedek tutunuz ve hosting firmanızın haftalık aldığı yedeğe bağlı kalmayın. Bazı hosting firmalarında “Eee kul yapısı” matığı ile yedek alınıyor ve istediğinizinde bulamayabiliyorsunuz. Otomatik Yedekeleme için öneri eklentim UpdraftPlus Backup and Restoration. Bu eklenti ile site yedeğinizi, veritabanı ile birlikte Google Drive ve diğer cloud servislerine, FTP adresinize, E-Postanıza ve daha bir çok yere aktarabiliyorsunuz.
  3. Kullanmadığınız WordPress temalarını ve ekletileri silin.WordPress ‘te gelen güvenlik açık olduğunda temalar ve ekletilerde bu güvenlik açığına dahil olabilir. Yukarıda belirttiğim hacklenen 62 sitenin büyük bir kısmından yapılan işlevlerden biri wordpress varsayılan temaların içeriğinin değiştirilip aktif olmasıydı. Kendi eklediğim temalarımın çoğu sağlamdı. Bu nedenle eğer siz de bu varsayılan temaları kullanmıyor iseniz bunları silmenizi öneririm. Eğer temaları ve eklentileri kullanıyorsanız yine otomatik güncellemeyi açık tutmanızı öneririm.
  4. Güvenlik AyarlarıWordPress ‘in güncellemeleri ile gelen güvenliğin haricinde bir güvenlik önlemi de siz alın. Bununla ilgili bir çok eklenti var benim bununla ilgili iki önerim var. Wordfence Security ve All In One WP Security & Firewall. Bu eklentiler ile ilgili gerekli yapılandırmayı kendi adreslerinden alabilirsiniz. Yine belirtmek isterim ki çok kritik güvenlik açıklarında bu eklentilere bel bağlamayın.

Unutmayın sitenize ne yaparsanız yapın yedeklemeden yapmayın ! Umarız WordPress bir sonrakisürümünde güvenlik güncellemeleri ile değilde yepyeni özellikleri ile birlikte gelir. WordPress Türkçe 4.2.4 sürümünü de güvenlik nedeni ile güncellemek zorunda kalmayız. Mutlu bloglamalar….

Beğenebilecekleriniz Bu yazarın diğer yazıları

Leave A Reply

Your email address will not be published.